FluentSnippets · Security record
Is FluentSnippets safe?
No known vulnerability affects the current version (10.58). 1 issue was found in earlier versions and fixed, the latest disclosed on Jul 16, 2025.
Checked 3 days ago against the WPVulnerability database, for version 10.58.
How it’s looked after
- Last release
- Oct 23, 2026 (2 weeks ago)
- Releases in the last year
- 6
- Tested up to
- WordPress 7.1.4
- Support resolved
- 3 of 3 threads in two months
- Active installs
- 50K+
1 known vulnerability
- 1 critical
None affects the current version.
Every known vulnerability in FluentSnippets
Newest first, with any that affect the current version at the top.
- critical
Cross-Site Request Forgery
Fixed in 10.51 · CVE-2025-54010 · Jul 16, 2025 · Wordfence
Questions about FluentSnippets’s security
Is FluentSnippets safe to use?
No known vulnerability affects its current version. Earlier versions had issues that are now fixed, so keep FluentSnippets updated: most attacks target sites that haven’t updated.
Does FluentSnippets have known security vulnerabilities?
None that affect the current version. WPVulnerability’s database lists 1 older issue, fixed in earlier versions, so keep FluentSnippets up to date.
Is FluentSnippets still maintained?
Yes. Its last release was 2 weeks ago. Its authors resolved 3 of the 3 support threads opened in the last two months.
Is FluentSnippets compatible with the latest WordPress?
Yes. It’s tested up to WordPress 7.1.4, the current version.
Hear about the next one first
Track your plugin on TrackWP and get an alert when a new vulnerability affecting it is published. Every plan has it, the free Starter too; Boost and FullCharge email it at once.
Start freeVulnerability data from WPVulnerability (CC0), which gathers records from CVE, Wordfence, Patchstack and WPScan. A clean record isn’t a guarantee: keep every plugin updated.