Simple Restrict · Security record
Is Simple Restrict safe?
No known vulnerability affects the current version (1.2.9). 3 issues were found in earlier versions and fixed, the latest disclosed on Jul 20, 2026.
Checked 1 day ago against the WPVulnerability database, for version 1.2.9.
How it’s looked after
- Last release
- Jul 15, 2026 (3 months ago)
- Releases in the last year
- 2
- Tested up to
- WordPress 7.0.8
- Active installs
- 1K+
3 known vulnerabilities
- 2 medium
- 1 not rated
None affects the current version.
Disclosed each year
- 20242
- 20261
Every known vulnerability in Simple Restrict
Newest first, with any that affect the current version at the top.
Fixed in 1.2.9 · CVE-2026-15939 · Jul 20, 2026 · Wordfence
Fixed in 1.2.8 · CVE-2024-11106 · Dec 9, 2024 · Wordfence
Fixed in 1.2.7 · CVE-2024-1083 · Mar 7, 2024 · Wordfence
Questions about Simple Restrict’s security
Is Simple Restrict safe to use?
No known vulnerability affects its current version. Earlier versions had issues that are now fixed, so keep Simple Restrict updated: most attacks target sites that haven’t updated.
Does Simple Restrict have known security vulnerabilities?
None that affect the current version. WPVulnerability’s database lists 3 older issues, fixed in earlier versions, so keep Simple Restrict up to date.
Is Simple Restrict still maintained?
Yes. Its last release was 3 months ago. No support threads were opened in the last two months.
Is Simple Restrict compatible with the latest WordPress?
It’s tested up to WordPress 7.0.8, one version behind the current 7.1. Authors often update this line a few weeks after a release.
Hear about the next one first
Track your plugin on TrackWP and get an alert when a new vulnerability affecting it is published. Every plan has it, the free Starter too; Boost and FullCharge email it at once.
Start freeVulnerability data from WPVulnerability (CC0), which gathers records from CVE, Wordfence, Patchstack and WPScan. A clean record isn’t a guarantee: keep every plugin updated.