Postie · Security record
Is Postie safe?
No known vulnerability affects the current version (1.9.89). 7 issues were found in earlier versions and fixed, the latest disclosed on Dec 31, 2025.
Checked 2 days ago against the WPVulnerability database, for version 1.9.89.
How it’s looked after
- Last release
- Nov 6, 2026 (2 days ago)
- Releases in the last year
- 15
- Tested up to
- WordPress 7.1.4
- Support resolved
- 4 of 6 threads in two months
- Active installs
- 10K+
7 known vulnerabilities
- 5 medium
- 2 not rated
None affects the current version.
Disclosed each year
- 20121
- 20203
- 20253
Every known vulnerability in Postie
Newest first, with any that affect the current version at the top.
Fixed in 1.9.88 · CVE-2026-100175 · Dec 31, 2025 · Wordfence
Fixed in 1.9.74 · CVE-2025-63020 · Dec 31, 2025 · Wordfence
Fixed in 1.9.71 · CVE-2024-5200 · Sep 8, 2025 · Wordfence
Fixed in 1.9.41 · Jan 6, 2020 · Patchstack
- medium
Cross-Site Scripting
Fixed in 1.9.41 · CVE-2019-20204 · Jan 1, 2020 · Wordfence
Fixed in 1.9.41 · CVE-2019-20203 · Jan 1, 2020 · Wordfence
Fixed in 1.5.15 · CVE-2012-2580 · Aug 8, 2012 · Wordfence
Questions about Postie’s security
Is Postie safe to use?
No known vulnerability affects its current version. Earlier versions had issues that are now fixed, so keep Postie updated: most attacks target sites that haven’t updated.
Does Postie have known security vulnerabilities?
None that affect the current version. WPVulnerability’s database lists 7 older issues, fixed in earlier versions, so keep Postie up to date.
Is Postie still maintained?
Yes. Its last release was 2 days ago. Its authors resolved 4 of the 6 support threads opened in the last two months.
Is Postie compatible with the latest WordPress?
Yes. It’s tested up to WordPress 7.1.4, the current version.
Hear about the next one first
Track your plugin on TrackWP and get an alert when a new vulnerability affecting it is published. Every plan has it, the free Starter too; Boost and FullCharge email it at once.
Start freeVulnerability data from WPVulnerability (CC0), which gathers records from CVE, Wordfence, Patchstack and WPScan. A clean record isn’t a guarantee: keep every plugin updated.