Poll Maker by AYS · Security record
Is Poll Maker by AYS safe?
No known vulnerability affects the current version (6.5.3). 24 issues were found in earlier versions and fixed, the latest disclosed on May 28, 2026.
Checked 2 days ago against the WPVulnerability database, for version 6.5.3.
How it’s looked after
- Last release
- Oct 23, 2026 (2 weeks ago)
- Releases in the last year
- 45
- Tested up to
- WordPress 7.1.4
- Support resolved
- 0 of 4 threads in two months
- Active installs
- 6K+
24 known vulnerabilities
- 7 high
- 17 medium
None affects the current version.
Disclosed each year
- 20213
- 20221
- 20234
- 20247
- 20258
- 20261
Every known vulnerability in Poll Maker by AYS
Newest first, with any that affect the current version at the top.
Fixed in 6.3.8 · CVE-2026-8995 · May 28, 2026 · Wordfence
Fixed in 6.0.8 · CVE-2025-12620 · Nov 12, 2025 · Wordfence
Fixed in 6.0.3 · CVE-2025-57954 · Sep 22, 2025 · Wordfence
Fixed in 5.9.0 · CVE-2024-12575 · Aug 15, 2025 · Wordfence
Fixed in 5.7.8 · CVE-2025-47545 · May 7, 2025 · Wordfence
Fixed in 5.5.4 · CVE-2024-13602 · Feb 23, 2025 · Wordfence
Fixed in 5.6.6 · CVE-2025-26971 · Feb 23, 2025 · Wordfence
Fixed in 5.5.5 · CVE-2024-56277 · Jan 3, 2025 · Wordfence
- medium
Missing Authorization
Fixed in 5.5.7 · CVE-2024-56295 · Jan 3, 2025 · Wordfence
- medium
Missing Authorization
Fixed in 5.5.1 · CVE-2025-24577 · Dec 15, 2024 · Wordfence
Fixed in 5.5.5 · CVE-2024-12115 · Dec 6, 2024 · Wordfence
Fixed in 5.4.7 · CVE-2024-9874 · Nov 8, 2024 · Wordfence
Fixed in 5.4.7 · CVE-2024-9462 · Oct 25, 2024 · Wordfence
Fixed in 5.4.7 · CVE-2024-9475 · Oct 25, 2024 · Wordfence
Fixed in 5.1.9 · CVE-2024-3600 · Apr 18, 2024 · Wordfence
Fixed in 5.1.9 · CVE-2024-3601 · Apr 18, 2024 · Wordfence
- medium
Missing Authorization
Fixed in 4.8.1 · CVE-2023-50904 · Dec 26, 2023 · Wordfence
- medium
Missing Authorization
Fixed in 4.7.2 · CVE-2023-45766 · Oct 12, 2023 · Wordfence
Fixed in 4.7.1 · CVE-2023-41871 · Sep 5, 2023 · Wordfence
Fixed in 4.6.3 · CVE-2023-34013 · Jun 26, 2023 · Wordfence
Fixed in 4.0.2 · CVE-2022-1456 · May 4, 2022 · Wordfence
Fixed in 3.4.2 · CVE-2021-24651 · Sep 13, 2021 · Wordfence
Fixed in 3.2.9 · CVE-2021-34635 · Jul 26, 2021 · Wordfence
- high
SQL Injection
Fixed in 3.2.1 · CVE-2021-24483 · Jun 29, 2021 · Wordfence
Questions about Poll Maker by AYS’s security
Is Poll Maker by AYS safe to use?
No known vulnerability affects its current version. Earlier versions had issues that are now fixed, so keep Poll Maker by AYS updated: most attacks target sites that haven’t updated.
Does Poll Maker by AYS have known security vulnerabilities?
None that affect the current version. WPVulnerability’s database lists 24 older issues, fixed in earlier versions, so keep Poll Maker by AYS up to date.
Is Poll Maker by AYS still maintained?
Yes. Its last release was 2 weeks ago. Its authors resolved 0 of the 4 support threads opened in the last two months.
Is Poll Maker by AYS compatible with the latest WordPress?
Yes. It’s tested up to WordPress 7.1.4, the current version.
Hear about the next one first
Track your plugin on TrackWP and get an alert when a new vulnerability affecting it is published. Every plan has it, the free Starter too; Boost and FullCharge email it at once.
Start freeVulnerability data from WPVulnerability (CC0), which gathers records from CVE, Wordfence, Patchstack and WPScan. A clean record isn’t a guarantee: keep every plugin updated.